COMPUTER NETWORKS
PROTOCOL INSPECTOR

LABORATORY WORK NO. 7
PROTOCOL INSPECTOR 
1. Objectives
The object of this lab is to explain how to use Fluke Networks Protocol Inspector for analyzing traffic in a network and the data frames. 
2. Theoretical considerations

2.1 Introduction
Fluke Networks' OPV-PE is an application that runs under Windows (2k, NT 4.x, XP). It’s an application for analyzing and monitoring Ethernet 10/100/1000 Networks. OPV-PE helps for monitoring networks.
OPV-PE's user interface provides both a comprehensive view of the network as well as the ability to easily drill down to a specific network segment. OPV-PE's main window provides a single, user-defined view for each of the segments being monitored. 
OPV-PE typically interfaces with one or more of Fluke Networks' hardware analyzer tools. OPV-PE can simultaneously capture, monitor, and analyze multiple devices, plus analyze captured data. OPV-PE monitors local network segments; the optional Remote software allows Fluke Networks software to communicate with Fluke Networks hardware and access Fluke Networks products on remote segments. 
2.2 Network Configuration (attaching computers to a local network)

The minimal equipment for using Protocol Inspector properly is made up of one router, a switch and a computer. It’s recommended to test a large network (school’s network), to find a large variety and number of devices attached.

2.3 Viewing data using Protocol Inspector

There are four main Protocol Inspector views, which include the following:

1. Summary View
2. Detail View
3. Capture View of Capture Buffers
4. Capture View of Capture Files
2.3.1 Summary View
The program opens in the Summary View. This view shows several windows used by the tool. The Resource Browser window in the upper left corner shows the only monitoring network device. The Alarm Browser on the left side and Message Area at the bottom will be covered later. The Monitor View, which is in the main window on the upper right, monitors one resource per window in a variety of viewing options. The Stop in the upper-left corner of the Monitor View window confirms that no monitoring is occurring.
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Figure 6.1
Start the Monitor / Capture process
To start the monitoring / capturing process, use the Start button or Module -> Start from the menu system. The Utilization chart should start showing activity like the graphic below:
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Figure 6.2
The word ARM should appear where Stop had been before. If opening the Module menu, notice that Stop is now an option while Start is muted. Do not stop the process yet. Restart it again if it is stopped.
The tabs at the bottom of the window show the resulting data in a variety of forms. Click on each and note the result. Transmit (Tx), Alarms, and Alarm Log will be blank. The following is the Received (Rx) frames, which indicates that Broadcast and Multicast frames are being received, but they may not show any Unicasts.
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Figure 6.3 
Using the console connection to the router, ping the monitoring host, and notice that Unicast frames appear. Unfortunately, the errors shown in the third column will not appear in the lab exercise unless a traffic generator like the Fluke Networks OptiView product has been added.
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Figure 6.4 
2.3.2 View Details

To go to the Detail View window click on the Detail View button in the toolbar or double click anywhere on the Monitor View chart. This will open a second window that should look something like the following, after maximizing the Utilization / Errors Strip Chart (RX) window.
Note: If necessary, activate all toolbars on the View menu.
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Figure 6.5
Initially, the chart output is the same as before. However, there are many more toolbar and menu options than in the Summary View. Before looking at these features, confirm that the Chart and Table tabs show the same information that was seen earlier.

Like all Windows compliant programs, placing the mouse over a button brings up a screen tip briefly identifying the purpose of the button. As the mouse moves over the buttons, notice that some are muted. This means that the feature is not appropriate under the current circumstances. In some cases, it is not supported in the educational version.
There is a complete display of the toolbars and what they do in the Appendix at the end of this lab. 
Click on the Mac Statistics button to see the Rx frame table data displayed in another format. The result should be obvious. Maximize the resulting window. The one piece of new information is the Speed, which shows the NIC transmission rate.
Click on the Frame Size Distribution button to see a distribution of the size frames being received by the NIC. Placing the mouse over any bar will display a small summary like the one shown below. Maximize the resulting window.
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Figure 6.6
Try the Pie, Bar, and Pause buttons in the upper-left corner. Note that the Pause stops the capture, so click on it again to resume the capture. Look at both the Table and Chart tab displays as well.

With the sample configurations, the student should be getting mainly small frames, because the only thing happening is routing updates. Try using the extended Ping feature from the router Console connection, and specify 100 pings with a larger packet size.
Click on the Protocol Distribution button to see a distribution of the protocols being received by the NIC. Placing the mouse over any bar will display a small summary panel. Maximize the resulting window.
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Figure 6.7
Try each of the buttons and tabs to see the results. The Net button shows only network protocols. The 323 button refers to the H323 Voiceover IP protocols. Look at the Frm (frame) and the Abs Bts (absolute bytes) and Rel Bts (relative bytes) to see the results. Remember that the Pause button stops the capture.
Click on the Host Table button to see the MAC stations and related traffic.
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Figure 6.8
Notice the Spanning Tree, AppleTalk, and OSPF traffic. Be sure to look at the Table tab to see the actual values.
Click on the Network Layer Host Table button to see the network (IP/IPX) stations and related traffic.
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Figure 6.9
Any pings and any additional hosts that might have added to the configuration will impact the actual addresses that appear on the right.
Click on the Application Layer Host Table button to see the network station traffic by application.
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Figure 6.10
Experiment with the next three buttons. They create host-to-host matrices for MAC, Network and Application layer conversations. The following is an example of the Network Layer (IP/IPX) conversations.
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Figure 6.11
Of the next two buttons, the first is the VLAN button that shows network traffic on VLANs. This sample does not use VLANs. Remember this button when troubleshooting VLANs later.
The second button creates a matrix comparing MAC and Network station addresses to names. 
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Figure 6.12
The Name Table button opens the current name table for viewing or editing.
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Figure 6.13
The Expert View button shows the expert symptoms discovered. These statistics are how the PIs try to point out potential problems. The underlined options bring up additional detail windows if there are any values recorded. The sample for this lab will not show much, but it will look over the options for debugging ISL, HSRP, and other types of problems that will be seen in later labs.
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Figure 6.13
2.3.3 Capture View of Capture Buffers
To stop the frame capture to look at individual frames use the Stop button or Module -> Stop from the menu.
Once the capture has been stopped, click on the Capture View button. With the education version, a message box appears announcing that the capture is limited to 250 packets. Just click OK.

The resulting window can be a little overwhelming at first. Maximize the window to hide any other windows open in the background.
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Figure 6.14
In looking over the results, note that there are actually three horizontal windows open. The top window lists the captured packets. The middle window shows the detail of the selected packet in the top window, and the bottom window shows the HEX values for the packet.
By positioning the mouse over the borders among the three windows, a line mover or two-headed arrow will appear. This allows the distribution of space for each window to be changed. It may be advantageous to make the middle window as large as possible and leave five to six rows in each of the other two, as shown above.
Look over the packets listed in the top window. DNS, ARP, RTMP, and other types of packets should be found. If using a switch, there should be CDP and Spanning Tree packets. Notice that as rows are selected in the top window, the contents of the other two windows change. 
Select information in the middle window, and notice that the HEX display in the bottom window changes to show where that specific information is stored. In the following example, selecting the Source Address (IP) shows HEX values from the packet.
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Figure 6.15
Note also the color coding makes it easier to locate information from the middle window in the HEX window. The corresponding HEX values are the same colors.
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Figure 6.16
Notice in the above example the EtherType is 0x0800. This indicates that it is an IP packet. Notice the MAC addresses for both the Destination and Source hosts as well as where that data is stored in the HEX display.
In the same example, the next section in the middle window is the User Datagram Protocol (UDP) information, which includes the UDP port numbers.
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Figure 6.17
The structure of the middle window changes for each type of packet. 
Take a few minutes to select different packet types in the top window, and then look over the resulting display in the other two windows. Pay particular attention to their Type, any port numbers, as well as source and destination addresses, which include both MAC and network layer. There should be RIP, OSPF, and RTMP packets in the capture. 

Study CDP or RIP packet, if exist.
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Figure 6.18
Study 
more packets and viewing modes and packet contents until comfortable with the tools.
2.3.4 Capture View of Capture Files
2.3.4.1 Saving capture data to a file
To save captured data, use the Save Capture button or choose File -> Save Capture from the menu system. Accept the All option by using the Continue button. The student can save just a range of captured frames with this window.
Use a proper file name and store the file on the appropriate disk. If the HST (or .CAP) extension is showing when this window opens, make sure it remains after typing the name.

Use the Open Capture File button to open a capture file. There is no difference in tools, but the title bar at the top of the screen indicates that a file is being viewed rather than a capture in memory.
2.3.4.2 Examine frames

Select a frame in the top window and try the buttons. The arrows by themselves move up or down one frame. The arrow with single line is top or bottom of the current window, while the arrow with two arrows is the top or bottom of the entire list. The arrow with the T also moves to the top of the list.
Use the Search buttons to perform searches. Type the text in the list box. Then click on the binoculars, and it will move from one text occurrence to the next.
3. Lab activity 
Experiment all 4 main Protocol Inspector views.
1. Open Protocol Inspector.
2. Start monitoring / capture process.
3. Notice the Utilization Chart and the information about sent and received data (Rx, Tx), all these being made up dynamically.
4. Double click on the Utilization Chart to open Detail View Window.
5. Test the results by pressing the buttons from Data Views Toolbar (MAC Statistics, Frame Size Distribution, Protocol Distribution, Utilization /Error, Host Table, Network Layer Host Table, Application Layer Host Table, Host Matrix, Network Layer Matrix, Application Layer Matrix, VLANs, Address Mapping, Expert View, Application Response Time). The results will be shown both as table and different chart type.
6. Inspect also Name Tables.
7. Stop the monitoring / capture process (after few minutes).
8.  Press Capture View button to see detailed information about the capture.
9. Study the contents of TCP, UDP, IPXRIP, DNS, ICMP, OSPF, ARP, RARP packets (source and destination address – both MAC and IP, length).
10. Save the capture in a file.
11. Build different examples to find frames using different search conditions.
4. Toolbars
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Function Keys

Function keys perform different operations with different Protocol Inspector views.
Table 6.1 
	Function 
Key
	Summary View
	Detail View

	F1
	Help
	Help

	F2
	System Settings
	Capture View Display Options

	F3
	Module Settings
	Module Settings

	F4
	Module Monitor View Preferences
	Create Display Filter

	F5
	Connect to Remote
	Create Capture Fitter

	F6
	Load Capture Filter
	Load Capture Filter

	F7
	Open Capture File
	Expert Summary View

	F8
	Save Capture
	Save Capture

	F9
	Go to Detail View
	Capture View

	F10
	Start / Stop
	Start / Stop
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